summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-06-20 12:59:56 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-20 13:13:56 +0200
commit6e6769dde0a3e613784834aeded53b3aaa2e4cec (patch)
tree2e9cbd6b98495c8a3838a36b84bfd19d6ae7fa5e /gnu
parent0bfafa49fa387c6a58f79178fc6344b2ce0bf02d (diff)
downloadguix-6e6769dde0a3e613784834aeded53b3aaa2e4cec.tar.gz
gnu: why3: Update to 1.3.3.
* gnu/packages/maths.scm (why3): Update to 1.3.3.
[arguments]: Adjust for newer ocaml-num.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a79d546abd..84540d5ffe 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6289,14 +6289,14 @@ numeric differences and differences in numeric formats.")
 (define-public why3
   (package
     (name "why3")
-    (version "1.3.1")
+    (version "1.3.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://gforge.inria.fr/frs/download.php/file"
-                                  "/38291/why3-" version ".tar.gz"))
+                                  "/38367/why3-" version ".tar.gz"))
               (sha256
                (base32
-                "16zcrc60zz2j3gd3ww93z2z9x2jkxb3kr57y8i5rcgmacy7mw3bv"))))
+                "1n0a2nn1gnk0zg339lh698g4wpk7m8m1vyi2yvifd5adqvk4milw"))))
     (build-system ocaml-build-system)
     (native-inputs
      `(("coq" ,coq)
@@ -6320,8 +6320,8 @@ numeric differences and differences in numeric formats.")
              (setenv "CONFIG_SHELL" (which "sh"))
              (substitute* "configure"
                ;; find ocaml-num in the correct directory
-               (("\\$DIR/nums.cma") "$DIR/../nums.cma")
-               (("\\$DIR/num.cmi") "$DIR/../num.cmi"))
+               (("\\$DIR/nums.cma") "$DIR/num.cma")
+               (("\\$DIR/num.cmi") "$DIR/core/num.cmi"))
              #t))
          (add-after 'configure 'fix-makefile
            (lambda _