summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <contact@phfrohring.com>2022-01-30 17:13:54 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-02 18:06:20 +0100
commit82a00693b74f507ca20bfd09b0aee0109ee8c455 (patch)
treeb0ecce51290c489a81462a4dc5d3573fe0f75923 /gnu
parent9cdce964caea6555de481f87a2994de16b092f2b (diff)
downloadguix-82a00693b74f507ca20bfd09b0aee0109ee8c455.tar.gz
gnu: Add python-types-dataclasses.
* gnu/packages/python-xyz.scm (python-types-dataclasses): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3be20df7e1..b65022ac90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28903,3 +28903,21 @@ but not binary streams.")
       "This package provides ECMAScript parsing infrastructure for
 multipurpose analysis in Python.")
     (license license:bsd-3)))
+
+(define-public python-types-dataclasses
+  (package
+    (name "python-types-dataclasses")
+    (version "0.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "types-dataclasses" version))
+              (sha256
+               (base32
+                "1mq6qd365m8ml889zl5dxj9kncjv71iq1d1fvgj59y0ixlpm6s35"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python/typeshed")
+    (synopsis "Typing stubs for dataclasses")
+    (description
+     "This packages provides a collection of library stubs for Python, with
+static types.")
+    (license license:asl2.0)))