summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:30 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commitac9c7d89d868f76da555538696f2e563463cebc6 (patch)
tree598bf0c011da6a2fc3926853c66694447f2d9a9d /gnu
parent65c6dba800dd41e23ad36cde4b11bc4d7ce0f10f (diff)
downloadguix-ac9c7d89d868f76da555538696f2e563463cebc6.tar.gz
gnu: Add trytond-production-split.
* gnu/packages/tryton.scm (trytond-production-split): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e787951718..9d497776e7 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2474,6 +2474,31 @@ the production.")
 routings for production: Routing, Step and Operation.")
     (license license:gpl3+)))
 
+(define-public trytond-production-split
+  (package
+    (name "trytond-production-split")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_production_split" version))
+       (sha256
+        (base32 "0jl2jnm0lwybwjw2w4nb7ih2s3z7lp00l6zm5vsx4phcvfvzcxgi"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "production_split"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-production" ,trytond-production)))
+    (home-page "https://docs.tryton.org/projects/modules-production-split")
+    (synopsis "Tryton module to split production")
+    (description "The @emph{Production Split} Tryton module adds on the
+production a wizard that allows to split it.  The production is split into
+productions of Quantity.  If a count is set, it will be split only this number
+of times.  On occasion there can be a production with the remaining
+quantity.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")