summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-06-16 23:02:45 +0800
committer宋文武 <iyzsong@gmail.com>2015-06-16 23:30:06 +0800
commitb9ecd5ae24126c9b461ccb9ddb5a276bee425574 (patch)
treef2bc05d3362745595965c5cc601b9476fbd7b008 /gnu
parenta33b8449a069cf104cbcc4ba96f885edb03b947e (diff)
downloadguix-b9ecd5ae24126c9b461ccb9ddb5a276bee425574.tar.gz
gnu: Add libmng.
* gnu/packages/image.scm (libmng): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 89590cc5ad..17da5f6391 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -563,3 +563,26 @@ with lossy compression and typically provides 3x smaller file sizes compared
 to PNG when lossy compression is acceptable for the red/green/blue color
 channels.")
     (license license:bsd-3)))
+
+(define-public libmng
+  (package
+    (name "libmng")
+    (version "2.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/libmng/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1lvxnpds0vcf0lil6ia2036ghqlbl740c4d2sz0q5g6l93fjyija"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+     ;; These are all in the 'Libs.private' field of libmng.pc.
+     `(("lcms" ,lcms)
+       ("libjpeg" ,libjpeg)
+       ("zlib" ,zlib)))
+    (home-page "http://www.libmng.com/")
+    (synopsis "Library for handling MNG files")
+    (description
+     "Libmng is the MNG (Multiple-image Network Graphics) reference library.")
+    (license license:bsd-3)))