summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-11 00:34:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 01:03:21 +0100
commitbfb7791cb0a456210c0bdde42e13847a4c8bee42 (patch)
tree98f9e4cad0b1eab6b946f64f7cd080c9dbd062e0 /gnu
parentfa6cc510ea5336f6be370edfc76a19d6519756cb (diff)
downloadguix-bfb7791cb0a456210c0bdde42e13847a4c8bee42.tar.gz
gnu: Add r-cachem.
* gnu/packages/cran.scm (r-cachem): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a2ddea2906..bcae733641 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -126,6 +126,30 @@ functions always read and write UTF-8 (8-bit Unicode Transformation Format)
 files and provide more explicit control over line endings.")
     (license license:expat)))
 
+(define-public r-cachem
+  (package
+    (name "r-cachem")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cachem" version))
+       (sha256
+        (base32
+         "0y3jb96lyn3vc3nq8gs9x669w3xp69vdg5xc69qy0l356r39gp3r"))))
+    (properties `((upstream-name . "cachem")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-fastmap" ,r-fastmap)
+       ("r-rlang" ,r-rlang)))
+    (home-page "https://cachem.r-lib.org/")
+    (synopsis "Cache R objects with automatic pruning")
+    (description
+     "This package provides key-value stores with automatic pruning.  Caches
+can limit either their total size or the age of the oldest object (or both),
+automatically pruning objects to maintain the constraints.")
+    (license license:expat)))
+
 (define-public r-diffobj
   (package
     (name "r-diffobj")