summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-01-28 05:02:13 -0500
committerLudovic Courtès <ludo@gnu.org>2022-02-05 00:59:30 +0100
commitdd823172d86f82dedf8b0a7eb65925db4b164d26 (patch)
treeb9071577593d840cd28828bbffb0e395fef40b92 /gnu
parent26da81afed73a35df65b7bf452eb56201ac17685 (diff)
downloadguix-dd823172d86f82dedf8b0a7eb65925db4b164d26.tar.gz
gnu: cppzmq: Update to 4.8.1.
* gnu/packages/networking.scm (cppzmq)[version]: Update to 4.8.1.
[arguments]: Update to run test suite except when cross-compiling.
[inputs]: Add catch2-framework.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3aa3e9b8e9..3ae255e093 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1152,7 +1152,7 @@ between different versions of ØMQ.")
 (define-public cppzmq
   (package
     (name "cppzmq")
-    (version "4.6.0")
+    (version "4.8.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1160,19 +1160,15 @@ between different versions of ØMQ.")
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "19acx2bzi4n6fdnfgkja1nds7m1bwg8lw5vfcijrx9fv75pa7m8h"))
+                "0zzq20wzk5grshxfqhqgqqfwb38w3k83r821isvyaxghsglpwks3"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
-     '(;; FIXME: The test suite requires downloading Catch and custom
-       ;; CMake targets, and refuses to use the system version.
-       ;; See <https://github.com/zeromq/cppzmq/issues/334>.
-       #:tests? #f
-       #:configure-flags '("-DCPPZMQ_BUILD_TESTS=OFF")))
+     `(#:tests? ,(not (%current-target-system)))) ; run unless cross-compiling
     (native-inputs
      (list pkg-config))
     (inputs
-     (list zeromq))
+     (list catch-framework2 zeromq))
     (home-page "https://zeromq.org")
     (synopsis "C++ bindings for the ØMQ messaging library")
     (description