summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-11 11:00:18 -0500
committerLeo Famulari <leo@famulari.name>2019-02-15 10:16:18 -0500
commite191e8485950477b2da37f23fd0d611e1e3f92e0 (patch)
tree21cd5f443bebc8a97c23149f246e72cd204f28a1 /gnu
parent867e2b1bb32cef651200cdd65042557f5c808909 (diff)
downloadguix-e191e8485950477b2da37f23fd0d611e1e3f92e0.tar.gz
gnu: Borg: Update to 1.1.9.
* gnu/packages/backup.scm (borg): Update to 1.1.9.
[arguments]: Remove the 'remove-documentation-timestamps' phase and adjust the
'install-doc' phase to ensure the manual pages are not a source of
non-determinism.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 970d0adb06..4881ca62da 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -512,14 +512,14 @@ detection, and lossless compression.")
 (define-public borg
   (package
     (name "borg")
-    (version "1.1.8")
+    (version "1.1.9")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgbackup" version))
        (sha256
         (base32
-         "0qqvcscn1l4y83x4sh3izdpmr8zq38j8chjkpfq4q4d01i470hqb"))
+         "0x95nhv4h34m8cxycbwc4xdz350saaxlgh727b23bgn4ci7gh3vx"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -565,11 +565,6 @@ detection, and lossless compression.")
                ;; HOME=/homeless-shelter.
                (setenv "HOME" "/tmp")
                #t)))
-         (add-after 'unpack 'remove-documentation-timestamps ; reproducibility
-           (lambda _
-             (substitute* "setup.py"
-               (("write\\(':Date:'.*") "\n"))
-             #t))
          ;; The tests need to be run after Borg is installed.
          (delete 'check)
          (add-after 'install 'check
@@ -606,8 +601,6 @@ detection, and lossless compression.")
                          '("docs/misc/create_chunker-params.txt"
                            "docs/misc/internals-picture.txt"
                            "docs/misc/prune-example.txt"))
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python3" "setup.py" "build_man")
                (copy-recursively "docs/man" man)
                #t))))))
     (native-inputs