summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 10:47:35 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 16:35:03 -0400
commite8e33c4ac3c808914310b02df3193ce4a4591cd4 (patch)
tree74086ca5b335926b7970dcc4bc79c014f1e3ed5c /gnu
parent4d170cfb1359c603511a162113dd902e9dcf324d (diff)
downloadguix-e8e33c4ac3c808914310b02df3193ce4a4591cd4.tar.gz
gnu: yelp-xsl: Enable documentation.
* gnu/packages/gnome.scm (yelp-xsl) [arguments]<#:configure-flag>
[--enable-doc]: New flag.
[native-inputs]: Add mallard-ducktype, intltool and libxslt.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1b3bff8fcc..b0ace8c883 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6810,10 +6810,17 @@ of running programs and invoke methods on those interfaces.")
        (sha256
         (base32 "1bdpgkzawhqmw52l6zx8czzg1ndfgcf1p44m2bxjdpqkc4afcgqc"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--enable-doc")))
     (native-inputs
-     `(("gettext-minimal" ,gettext-minimal)
+     `(("ducktype" ,mallard-ducktype)
+       ("gettext" ,gettext-minimal)
+       ("intltool" ,intltool)
        ("itstool" ,itstool)
-       ("xmllint" ,libxml2)))
+       ("xmllint" ,libxml2)
+       ("xsltproc" ,libxslt)))
     (synopsis "XSL stylesheets for Yelp")
     (description "Yelp-XSL is a collection of programs and data files to help
 you build, maintain, and distribute documentation.  It provides XSLT stylesheets