summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-06 10:10:44 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-06 10:10:44 +0100
commiteefbec5595aa538df13a20cc4a2a0e97dee8a6e5 (patch)
tree730f2359478069dfb13209a73ae0a98d6ac3e3ec /gnu
parent896ca880b643622017d6d141d5ab340b165b0fc0 (diff)
downloadguix-eefbec5595aa538df13a20cc4a2a0e97dee8a6e5.tar.gz
gnu: emacs-marginalia: Update to 0.2.
* gnu/packages/emacs-xyz.scm (emacs-marginalia): Update to 0.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm40
1 files changed, 18 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 967ffbde32..04f22fe72f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7194,31 +7194,27 @@ list of candidates.")
     (license license:gpl3+)))
 
 (define-public emacs-marginalia
-  ;; There are no tagged releases upstream on GitHub, instead we are using the
-  ;; most recent commit.
-  (let ((commit "401993562dbf636054dd64988e44d19b5030867f")
-        (revision "0"))
-    (package
-      (name "emacs-marginalia")
-      (version (git-version "0.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/minad/marginalia")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1j0k9ija5paidj7yvbagkkayz9bjwhia9yhmd2q4490ginbbxshs"))))
-      (build-system emacs-build-system)
-      (home-page "https://github.com/minad/marginalia")
-      (synopsis "Marginalia in the minibuffer")
-      (description
-       "This package provides Marginalia mode which adds marginalia to the
+  (package
+    (name "emacs-marginalia")
+    (version "0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/minad/marginalia")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0lbng4l5h3c61m9pbgnwzp89y40b71l8ygf5r98m8yagqzvxjaj1"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/minad/marginalia")
+    (synopsis "Marginalia in the minibuffer completions")
+    (description
+     "This package provides Marginalia mode which adds marginalia to the
 minibuffer completions.  Marginalia are marks or annotations placed at the
 margin of the page of a book or in this case helpful colorful annotations
 placed at the margin of the minibuffer for your completion candidates.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-smartparens
   (package