summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 15:22:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:00 -0400
commitf35d65707cb15f62f8924b245baca4ad929d309b (patch)
tree2a3b2ecda359db2cb49ec75f090656a2f71e1f36 /gnu
parentdaf2b257555b1f8a21020369eb77189a66abd96d (diff)
downloadguix-f35d65707cb15f62f8924b245baca4ad929d309b.tar.gz
gnu: python-celery: Update to 5.2.6 and enable tests.
* gnu/packages/python-xyz.scm (python-celery): Update to 5.2.6.
[tests?]: Delete argument.
[phases]{delete-integration-tests}: Delete phase.
{relax-requirements}: New phase.
{check}: Ignore the "t/integration" directory and the
t/unit/backends/test_mongodb.py file.  Remove skip directive for
test_all_reqs_enabled_in_tests.
[native-inputs]: Add python-dnspython.
[propagated-inputs]: Delete python-boto3 and python-cryptography.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 18 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfae08fa7c..cd44113352 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15821,31 +15821,37 @@ Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
 (define-public python-celery
   (package
     (name "python-celery")
-    (version "5.1.2")                  ;newer versions require python-click>=8
+    (version "5.2.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "celery" version))
        (sha256
-        (base32 "1c6lw31i3v81fyj4yn37lbvv70xdgb389iccirzyjr992vlkv6ld"))))
+        (base32 "109lcqarrbmh95sk1dm4yxayq1h3i27f4w23ndk64mqgyfnqqffi"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'delete-integration-tests
+         (add-after 'unpack 'relax-requirements
            (lambda _
-             (delete-file-recursively "t/integration"))) ;hangs tests
+             (substitute* "requirements/default.txt"
+               (("pytz.*")
+                "pytz\n"))))
          (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+           (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest" "t" "-k"
-                       (string-append   ; AssertionErrors
-                        "not test_check_privileges_no_fchown"
-                        " and not test_all_reqs_enabled_in_tests"))))))))
+               (invoke "python" "-m" "pytest" "t"
+                       "--ignore" "t/integration" ;hangs tests
+                       ;; The MongoDB backend test appears to expect an older
+                       ;; version of MongoDB which provided its own bson
+                       ;; module, fails with " AttributeError: module 'bson'
+                       ;; has no attribute 'encode'".
+                       "--ignore" "t/unit/backends/test_mongodb.py"
+                       ;; AssertionErrors
+                       "-k" "not test_check_privileges_no_fchown ")))))))
     (native-inputs
      (list python-case
+           python-dnspython
            python-flaky
            python-iniconfig
            python-moto
@@ -15857,12 +15863,10 @@ Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
            python-toml))
     (propagated-inputs
      (list python-billiard
-           python-boto3
            python-click
            python-click-didyoumean
            python-click-plugins
            python-click-repl
-           python-cryptography
            python-kombu
            python-pytz
            python-vine))