summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-19 23:21:11 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:25 +0200
commit016b4fc307089e5b94bf15bb2af63dede8306917 (patch)
tree8df8f8a2d017d30176c0129d0d7ca7cf3dddc7a6 /gnu
parentbfce6286176955a3d888586ecbf5a44a13b6ce6e (diff)
downloadguix-016b4fc307089e5b94bf15bb2af63dede8306917.tar.gz
gnu: dstat: Add bash-minimal to inputs and use gexps.
* gnu/packages/admin.scm (dstat) [inputs]: Add bash-minimal.
[arguments]: Use gexps.  Delete trailing #t.

Change-Id: Ia0635f39dfbc09be96690be678d1ad22983b6c08
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index dcbaa8877a..387476a9f4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3494,26 +3494,26 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
                                 "dstat-skip-devices-without-io.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no make check
-       #:make-flags
-       (list (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-python3-DeprecationWarning
-           (lambda _
-             (substitute* "dstat"
-               (("collections") "collections.abc"))
-             #t))
-         (delete 'configure)            ; no configure script
-         (add-after 'install 'wrap
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (wrap-program (string-append out "/bin/dstat")
-                 `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))
-               #t))))))
+     (list
+      #:tests? #f                       ; no make check
+      #:make-flags
+      #~(list (string-append "prefix=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-python3-DeprecationWarning
+            (lambda _
+              (substitute* "dstat"
+                (("collections") "collections.abc"))))
+          (delete 'configure)           ; no configure script
+          (add-after 'install 'wrap
+            (lambda _
+              (wrap-program (string-append #$output "/bin/dstat")
+                `("GUIX_PYTHONPATH" ":" prefix
+                  (,(getenv "GUIX_PYTHONPATH")))))))))
     (inputs
-     `(("python" ,python-wrapper)
-       ("python-six" ,python-six)))
+     (list bash-minimal                 ;for wrap-program
+           python-wrapper
+           python-six))
     (synopsis "Versatile resource statistics tool")
     (description "Dstat is a versatile replacement for @command{vmstat},
 @command{iostat}, @command{netstat}, and @command{ifstat}.  Dstat overcomes