summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:10:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:54 +0200
commit016ce334180c8a96597987de9cc5729b742c71b7 (patch)
treed92a02bab9aa22c305207a3f9956d68365274fb5 /gnu
parent5ac51dbe3ec62e2c9fe5a55dbad36aeb89d195ff (diff)
downloadguix-016ce334180c8a96597987de9cc5729b742c71b7.tar.gz
gnu: Add texlive-hexgame.
* gnu/packages/tex.scm (texlive-hexgame): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f77ee94bce..cdc8ff4a4b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7490,6 +7490,25 @@ existing SIunits set.")
 and XeTeX, that provides functionality for drawing Hex boards and games.")
     (license license:cc-by-sa4.0)))
 
+(define-public texlive-hexgame
+  (package
+    (name "texlive-hexgame")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/hexgame/" "tex/latex/hexgame/")
+             (base32
+              "1qr9v7225k6xzykw3rdsxf2sa3b5asvmd767i88jwimmacwi2cp1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hexgame")
+    (synopsis "Provide an environment to draw a hexgame-board")
+    (description
+     "Hex is a mathematical game invented by the Danish mathematician Piet
+Hein and independently by the mathematician John Nash.  This package defines
+an environment that enables the user to draw such a game in a trivial way.")
+    (license license:lppl)))
+
 (define-public texlive-hitex
   (package
     (name "texlive-hitex")