summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-18 17:28:43 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:46 +0200
commit02e43504b36169d211b4bf348e2340f018c763a8 (patch)
treedacd32faa384e3a98fcfbc40ae9d707c94560956 /gnu
parent391ce2ea752c9eb43e47a1e97b1e13aaf6a63385 (diff)
downloadguix-02e43504b36169d211b4bf348e2340f018c763a8.tar.gz
gnu: grep: Use gexps.
* gnu/packages/base.scm (grep)[arguments]: Use gexps.

Change-Id: I7311667b8b929161d1e7290ddfe37c0e875364b2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm65
1 files changed, 32 insertions, 33 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d58fe59b0b..f45bcd6ff2 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -132,39 +132,38 @@ command-line arguments, multiple languages, and so on.")
    (native-inputs (list perl))                   ;some of the tests require it
    (inputs (list pcre2))
    (arguments
-    `(#:configure-flags
-      (list "--enable-perl-regexp")
-
-      ;; XXX: On 32-bit Hurd platforms, 'time_t' is defined as a 32-bit
-      ;; integer in 'hurd_types.defs', so this Gnulib test always fails.
-      #:make-flags ,(if (and (not (%current-target-system))
-                             (string=? (%current-system) "i586-gnu"))
-                        ''("XFAIL_TESTS=test-year2038")
-                        ''())
-
-      #:phases
-      (modify-phases %standard-phases
-        (add-after 'install 'fix-egrep-and-fgrep
-          ;; Patch 'egrep' and 'fgrep' to execute 'grep' via its
-          ;; absolute file name instead of searching for it in $PATH.
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let* ((out (assoc-ref outputs "out"))
-                   (bin (string-append out "/bin")))
-              (substitute* (list (string-append bin "/egrep")
-                                 (string-append bin "/fgrep"))
-                (("^exec grep")
-                 (string-append "exec " bin "/grep"))))))
-        ,@(if (system-hurd?)
-              '((add-before 'check 'skip-test
-                  (lambda _
-                    (substitute*
-                        ;; This test hangs
-                        '("tests/hash-collision-perf"
-                          ;; This test fails
-                          "tests/file")
-                      (("^#!.*" all)
-                       (string-append all "exit 77;\n"))))))
-              '()))))
+    (list #:configure-flags #~(list "--enable-perl-regexp")
+
+          ;; XXX: On 32-bit Hurd platforms, 'time_t' is defined as a 32-bit
+          ;; integer in 'hurd_types.defs', so this Gnulib test always fails.
+          #:make-flags
+          #~#$(if (and (not (%current-target-system))
+                       (string=? (%current-system) "i586-gnu"))
+                  #~'("XFAIL_TESTS=test-year2038")
+                  #~'())
+
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-after 'install 'fix-egrep-and-fgrep
+                ;; Patch 'egrep' and 'fgrep' to execute 'grep' via its
+                ;; absolute file name instead of searching for it in $PATH.
+                (lambda* (#:key outputs #:allow-other-keys)
+                  (let* ((out (assoc-ref outputs "out"))
+                         (bin (string-append out "/bin")))
+                    (substitute* (list (string-append bin "/egrep")
+                                       (string-append bin "/fgrep"))
+                      (("^exec grep")
+                       (string-append "exec " bin "/grep"))))))
+              #$@(if (system-hurd?)
+                     #~((add-before 'check 'skip-test
+                          (lambda _
+                            (substitute* ;; This test hangs
+                                '("tests/hash-collision-perf"
+                                  ;; This test fails
+                                  "tests/file")
+                              (("^#!.*" all)
+                               (string-append all "exit 77;\n"))))))
+                     #~()))))
    (synopsis "Print lines matching a pattern")
    (description
      "grep is a tool for finding text inside files.  Text is found by