summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 18:44:32 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:30 +0200
commit033b098de867987c46027824500def6cba1d731c (patch)
tree3790e6311df74d5ae93fd59e47c22373946c1682 /gnu
parentecc528c3691f7bfc1039cbdbd622ed3ed54fff05 (diff)
downloadguix-033b098de867987c46027824500def6cba1d731c.tar.gz
gnu: Add rust-intervaltree-0.2.
* gnu/packages/crates-io.scm (rust-intervaltree-0.2): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 021406c8fa..4044ab1887 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2792,6 +2792,31 @@ renamed to indexmap.")
      "This package provides a snapshot testing library for Rust.")
     (license license:asl2.0)))
 
+(define-public rust-intervaltree-0.2
+  (package
+    (name "rust-intervaltree")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "intervaltree" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "10k40gsv79kwnsqrzwmnmm6psa5fqws8yggavmbggvymv16hffdg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-smallvec" ,rust-smallvec-0.6))))
+    (home-page "https://github.com/main--/rust-intervaltree")
+    (synopsis "Immutable interval trees")
+    (description
+     "This package provides a simple and generic implementation of an
+immutable interval tree.")
+    (license license:expat)))
+
 (define-public rust-iovec-0.1
   (package
     (name "rust-iovec")