summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-06-13 08:22:29 +0400
committerAndrew Tropin <andrew@trop.in>2023-06-13 08:25:57 +0400
commit0433e7f3c200936fbf77f22aa3b433413d17d0fa (patch)
tree1740ad938913ef1cc13c70afbd0a4e23e9a4c952 /gnu
parent5c66be3c17e279e4589320c69deb5dba0fd034e2 (diff)
downloadguix-0433e7f3c200936fbf77f22aa3b433413d17d0fa.tar.gz
gnu: Add emacs-rail.
* gnu/packages/emacs-xyz.scm (emacs-rail): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 24a4ae169e..f46af73aec 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15518,6 +15518,27 @@ can selectively commit files, view the diffs, and other things.")
 distribution, primarily targeting Clojure users")
     (license license:gpl3+)))
 
+(define-public emacs-rail
+  (package
+    (name "emacs-rail")
+    (version "0.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Sasanidas/Rail")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1i07zv0z6r46jpg22x99a1izyfp6536xf951ibyr9kis5bql5jz9"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Sasanidas/Rail")
+    (synopsis "Generic nREPL client for Emacs")
+    (description
+     "Rail is a nREPL client based on monroe with similar features, but aims
+to be a more complete implementation.")
+    (license license:gpl3+)))
+
 (define-public emacs-orgalist
   (package
     (name "emacs-orgalist")