summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:21:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:34 +0100
commit083c695d30902781f3e6257ebe1e4f9e2b84afdd (patch)
treeae630ae3ae08d2e045c4a1a27195388575ca1670 /gnu
parent92e1b5f32dd775a0ba5997a8fe0a73cb6dcf1d76 (diff)
downloadguix-083c695d30902781f3e6257ebe1e4f9e2b84afdd.tar.gz
gnu: wcstools: Sort alphabetically.
* gnu/packages/astronomy.scm (wcstools): Sort alphabetically.

Change-Id: I3422a4af474aac67b134cf8700e868f1c5d6341c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm66
1 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f65257c0b2..126aed8728 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1133,39 +1133,6 @@ header.")
                  (delete-file-recursively "C/flexed")))))
     (properties '((hidden? . #t)))))
 
-(define-public wcstools
-  (package
-    (name "wcstools")
-    (version "3.9.7")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "http://tdc-www.harvard.edu/software/wcstools/wcstools-"
-             version ".tar.gz"))
-       (sha256
-        (base32 "125hqzspvqrx6372smzsmxwg06ib2arjc5awnwnq53w1xdq6jpsj"))
-       (patches (search-patches "wcstools-extend-makefiles.patch"))))
-    (build-system gnu-build-system)
-    (arguments
-     (list
-      #:tests? #f ;No tests provided.
-      #:make-flags
-      #~(list (string-append "CC=" #$(cc-for-target))
-              (string-append "PREFIX=" #$output))
-      #:phases
-      #~(modify-phases %standard-phases
-          (delete 'configure))))
-    (home-page "http://tdc-www.harvard.edu/software/wcstools/")
-    (synopsis "Handle the WCS of a FITS image")
-    (description
-     "WCSTools is a set of software utilities, written in C, which create,
-display and manipulate the world coordinate system of a FITS or IRAF image,
-using specific keywords in the image header which relate pixel position within
-the image to position on the sky.  Auxillary programs search star catalogs and
-manipulate images.")
-    (license license:gpl2+)))
-
 (define-public glnemo2
   (package
     (name "glnemo2")
@@ -5304,6 +5271,39 @@ an API for performing input and output operations on different kinds of
 n-body file formats (nemo, Gadget binaries 1 and 2, Gadget hdf5, Ramses).")
       (license license:cecill))))
 
+(define-public wcstools
+  (package
+    (name "wcstools")
+    (version "3.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://tdc-www.harvard.edu/software/wcstools/wcstools-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "125hqzspvqrx6372smzsmxwg06ib2arjc5awnwnq53w1xdq6jpsj"))
+       (patches (search-patches "wcstools-extend-makefiles.patch"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f ;No tests provided.
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target))
+              (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
+    (home-page "http://tdc-www.harvard.edu/software/wcstools/")
+    (synopsis "Handle the WCS of a FITS image")
+    (description
+     "WCSTools is a set of software utilities, written in C, which create,
+display and manipulate the world coordinate system of a FITS or IRAF image,
+using specific keywords in the image header which relate pixel position within
+the image to position on the sky.  Auxillary programs search star catalogs and
+manipulate images.")
+    (license license:gpl2+)))
+
 (define-public weightwatcher
   (package
     (name "weightwatcher")