summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:58:57 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:10 +0300
commit08ff4fd1b1705ef0020f45a9b1da6f40f03cbe1d (patch)
tree6f7e583252bdc0c6002b3ad6acf20562304ef2ed /gnu
parent1bd3400d8c88bca7942f37029efd15731f58b16d (diff)
downloadguix-08ff4fd1b1705ef0020f45a9b1da6f40f03cbe1d.tar.gz
gnu: Add emacs-crux.
* gnu/packages/emacs.scm (emacs-crux): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b4499b634a..2d621ef122 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8661,3 +8661,27 @@ continue.")
 dumb text search, @code{elisp-refs} actually parses the code, so it's never
 confused by comments or @code{foo-bar} matching @code{foo}.")
     (license license:gpl3+)))
+
+(define-public emacs-crux
+  (let ((commit "4f5c8fefd5a6aa52e128c4a0401cc86410d6ac8f")
+        (revision "1"))
+    (package
+      (name "emacs-crux")
+      (version (string-append "0.3.0" "-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/bbatsov/crux.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "1fdxvv25cs01sg6fmvmzxpzvs50i6v8n2jya60lbavxqqhi0sbxd"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/bbatsov/crux")
+      (synopsis "Collection of useful functions for Emacs")
+      (description
+       "@code{crux} provides a collection of useful functions for Emacs.")
+      (license license:gpl3+))))