summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-20 14:32:47 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 17:19:59 +0100
commit0be8dd19903cbdc07a434bec5f6af1e640e3eef3 (patch)
tree85892728b4c9b082c7a5cf3a67aeba1821d9c1a2 /gnu
parent44c0b5d4673f994324d9a27b25298bfdd8edf2ae (diff)
downloadguix-0be8dd19903cbdc07a434bec5f6af1e640e3eef3.tar.gz
gnu: glew: Omit static library.
* gnu/packages/gl.scm (glew)[arguments]: Add phase to delete libGLEW.a.  While
at it, convert to G-expression.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gl.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d45e4f0d8e..00b04d0cc9 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -634,12 +634,15 @@ glxgears, glxheads, and glxinfo.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases (delete 'configure))
-       #:make-flags (list (string-append "GLEW_PREFIX="
-                                         (assoc-ref %outputs "out"))
-                          (string-append "GLEW_DEST="
-                                         (assoc-ref %outputs "out")))
-       #:tests? #f))                              ;no 'check' target
+     (list #:make-flags #~(list (string-append "GLEW_PREFIX=" #$output)
+                                (string-append "GLEW_DEST=" #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+               (add-after 'install 'delete-static
+                 (lambda _
+                   (delete-file (string-append #$output "/lib/libGLEW.a")))))
+           #:tests? #f))                ;no 'check' target
     (inputs
      (list libxi libxmu libx11 mesa))