summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-10 19:03:29 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-10 23:49:51 +0100
commit0d279640ceb8b14e8eaee6f89c38457dc9b03142 (patch)
tree45c9e94ba69343988ea74e160f2d6cf720cf0841 /gnu
parent785cbb09895e6f8db57bce2570e418a72fd3f9aa (diff)
downloadguix-0d279640ceb8b14e8eaee6f89c38457dc9b03142.tar.gz
gnu: Add rust-trust-dns-resolver-0.20.
* gnu/packages/crates-io.scm (rust-trust-dns-resolver-0.20): New variable.
(rust-trust-dns-resolver-0.19): Inherit from above.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm59
1 files changed, 49 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 686b8355fd..4a5473f89e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44721,8 +44721,56 @@ DNS protocol library for all Trust-DNS projects.")
        (("rust-env-logger" ,rust-env-logger-0.6)
         ("rust-tokio" ,rust-tokio-0.1))))))
 
+(define-public rust-trust-dns-resolver-0.20
+  (package
+    (name "rust-trust-dns-resolver")
+    (version "0.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "trust-dns-resolver" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1r2n933z9yrpdqv60c9mbhl64y2inpx9rm870nq1qqmx226d2wih"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-futures-util" ,rust-futures-util-0.3)
+        ("rust-ipconfig" ,rust-ipconfig-0.2)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-lru-cache" ,rust-lru-cache-0.1)
+        ("rust-parking-lot" ,rust-parking-lot-0.11)
+        ("rust-resolv-conf" ,rust-resolv-conf-0.7)
+        ("rust-rustls" ,rust-rustls-0.19)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-smallvec" ,rust-smallvec-1)
+        ("rust-thiserror" ,rust-thiserror-1)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+        ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+        ("rust-tokio-rustls" ,rust-tokio-rustls-0.22)
+        ("rust-trust-dns-https" ,rust-trust-dns-https-0.20)
+        ("rust-trust-dns-native-tls" ,rust-trust-dns-native-tls-0.20)
+        ("rust-trust-dns-openssl" ,rust-trust-dns-openssl-0.20)
+        ("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20)
+        ("rust-trust-dns-rustls" ,rust-trust-dns-rustls-0.20)
+        ("rust-webpki-roots" ,rust-webpki-roots-0.21))))
+    (home-page "http://www.trust-dns.org/index.html")
+    (synopsis "Safe and secure DNS library")
+    (description
+     "Trust-DNS is a safe and secure DNS library.  This Resolver library uses
+the Client library to perform all DNS queries.  The Resolver is intended to be
+a high-level library for any DNS record resolution see Resolver and
+AsyncResolver for supported resolution types.  The Client can be used for
+other queries.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-trust-dns-resolver-0.19
   (package
+    (inherit rust-trust-dns-resolver-0.20)
     (name "rust-trust-dns-resolver")
     (version "0.19.5")
     (source
@@ -44733,7 +44781,6 @@ DNS protocol library for all Trust-DNS projects.")
        (sha256
         (base32
          "0xqv31gndybcrr5gi6jjp47qcvdxsc147s69a0y0nc6qqgyws8qg"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:tests? #false                  ;network unreachable
        #:cargo-inputs
@@ -44761,15 +44808,7 @@ DNS protocol library for all Trust-DNS projects.")
         ("rust-webpki-roots" ,rust-webpki-roots-0.19))
        #:cargo-development-inputs
        (("rust-env-logger" ,rust-env-logger-0.7)
-        ("rust-futures" ,rust-futures-0.3))))
-    (home-page "http://www.trust-dns.org/index.html")
-    (synopsis "Safe and secure DNS library")
-    (description "Trust-DNS is a safe and secure DNS library.  This Resolver
-library uses the Client library to perform all DNS queries.  The Resolver is
-intended to be a high-level library for any DNS record resolution see Resolver
-and AsyncResolver for supported resolution types.  The Client can be used for
-other queries.")
-    (license (list license:expat license:asl2.0))))
+        ("rust-futures" ,rust-futures-0.3))))))
 
 (define-public rust-trust-dns-resolver-0.18
   (package