summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-06 20:34:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-06 20:39:45 +0200
commit12c613b54868d4b0894dc69063f3962f252ba6e8 (patch)
tree18760f9c3bb07df847c05adb2a3f1253ef6f6a9b /gnu
parentab8757c5b191ea6df39b5aba9797ac219d495c37 (diff)
downloadguix-12c613b54868d4b0894dc69063f3962f252ba6e8.tar.gz
gnu: dtc: Build python bindings.
* gnu/packages/bootloaders.scm (dtc)[native-inputs]: Add swig.
[inputs]: Add python-2.
[arguments]: Remove 'NO_PYTHON' from make-flags, add 'SETUP_PREFIX' to
set python bindings prefix.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 4ba7a93e4b..62282c99c8 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -43,6 +43,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
   #:use-module (gnu packages texinfo)
+  #:use-module (gnu packages swig)
   #:use-module (gnu packages virtualization)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
@@ -292,12 +293,15 @@ menu to select one of the installed operating systems.")
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
-       ("flex" ,flex)))
+       ("flex" ,flex)
+       ("swig" ,swig)))
+    (inputs
+     `(("python-2" ,python-2)))
     (arguments
      `(#:make-flags
        (list "CC=gcc"
              (string-append "PREFIX=" (assoc-ref %outputs "out"))
-             "NO_PYTHON=1"
+             (string-append "SETUP_PREFIX=" (assoc-ref %outputs "out"))
              "INSTALL=install")
        #:phases
        (modify-phases %standard-phases