summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:18:21 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:57 +0200
commit12dd3c5d2d8a2b6c574d1beda938cc4f65d45a0d (patch)
tree41e122a8f929ed9ba3c1569b33567593d66ae9f5 /gnu
parent189333f9c04f64d000c2a08478875806f9e691eb (diff)
downloadguix-12dd3c5d2d8a2b6c574d1beda938cc4f65d45a0d.tar.gz
gnu: perl6-json: Perl -> Raku.
* gnu/packages/perl6.scm (perl6-json): Extract commit outside of source.
[description]: Replace mention of Perl with Raku.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl6.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index d25afa5528..d8a5b5ad4a 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -359,27 +359,27 @@ have profiling information collected when the grammar is used.")
       (license license:artistic2.0))))
 
 (define-public perl6-json
-  (package
-    (name "perl6-json")
-    (version "1.0")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
+  ;; The commit where 1.0 was “tagged”.
+  (let ((commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99"))
+    (package
+      (name "perl6-json")
+      (version "1.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
                (url "https://github.com/moritz/json")
-               ;; The commit where 1.0 was "tagged"
-               (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
-    (build-system rakudo-build-system)
-    (arguments '(#:with-zef? #f))
-    (home-page "https://github.com/moritz/json")
-    (synopsis "Minimal JSON (de)serializer")
-    (description "This module is a simple Perl 6 module for serializing and
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
+      (build-system rakudo-build-system)
+      (arguments '(#:with-zef? #f))
+      (home-page "https://github.com/moritz/json")
+      (synopsis "Minimal JSON (de)serializer")
+      (description "This module is a simple Raku module for serializing and
 deserializing JSON.")
-    (license license:artistic2.0)))
+      (license license:artistic2.0))))
 
 (define-public perl6-json-class
   (package