summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 10:13:26 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:14 +0200
commit14f2988004f390c22eb49ad776bb02faa196e4a4 (patch)
tree0edd5837aecd13bcaa1697caf524357c89181ca6 /gnu
parent4b185ecc3cd87315f01781ca9d9f21f9a8eae9c4 (diff)
downloadguix-14f2988004f390c22eb49ad776bb02faa196e4a4.tar.gz
gnu: Add rust-futures-select-macro-preview-0.3.
* gnu/packages/crates-io.scm (rust-futures-select-macro-preview-0.3): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b15ce0d215..7c6fd8da76 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1382,6 +1382,35 @@ library.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-futures-select-macro-preview-0.3
+  (package
+    (name "rust-futures-select-macro-preview")
+    (version "0.3.0-alpha.17")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "futures-select-macro-preview" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1a90ivjzkgz7msiz5si05xzi8xwsk5gar1gkrbmrgqpgkliqd7a6"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-proc-macro-hack" ,rust-proc-macro-hack-0.5)
+        ("rust-proc-macro2" ,rust-proc-macro2-0.4)
+        ("rust-quote" ,rust-quote-1.0)
+        ("rust-syn" ,rust-syn-0.15))))
+    (home-page "https://github.com/rust-lang/futures-rs")
+    (synopsis
+     "Handle the first Future to complete")
+    (description
+     "The @code{select!} macro for waiting on multiple different
+@code{Future}s at once and handling the first one to complete.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-futures-sink-preview-0.3
   (package
     (name "rust-futures-sink-preview")