summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 14:38:44 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:30 -0500
commit152ce152b5f863003eacdcfa1ea1c05532499827 (patch)
tree81186a700c45a0016f9556a0a1f996949d433f63 /gnu
parent715a0c51bfbe44dd433f90ad103f816dd5b9cb8e (diff)
downloadguix-152ce152b5f863003eacdcfa1ea1c05532499827.tar.gz
gnu: Add Object-Signature.
* gnu/packages/perl.scm (perl-object-signature): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7f147ac35f..43a922f0e3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2283,6 +2283,26 @@ name, but they won't show up as methods on your class or instances.")
 subroutine, which you can call with a value to be tested against.")
     (license (package-license perl))))
 
+(define-public perl-object-signature
+  (package
+    (name "perl-object-signature")
+    (version "1.07")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+                           "Object-Signature-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0c8l7195bjvx0v6zmkgdnxvwg7yj2zq8hi7xd25a3iikd12dc4f6"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Object-Signature")
+    (synopsis "Generate cryptographic signatures for objects")
+    (description "Object::Signature is an abstract base class that you can
+inherit from in order to allow your objects to generate unique cryptographic
+signatures.")
+    (license (package-license perl))))
+
 (define-public perl-package-anon
   (package
     (name "perl-package-anon")