summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:46 +0200
commit15b134e6debb67f578b045c94e95d02b98757c2b (patch)
tree605625b2c8b9e4956b16113549b1a2bb37e8d69d /gnu
parent5aa4f9a9603f5c3dd173fcb45a6bcfb960744c6b (diff)
downloadguix-15b134e6debb67f578b045c94e95d02b98757c2b.tar.gz
gnu: Add texlive-termcal.
* gnu/packages/tex.scm (texlive-termcal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f1fb92a7ac..e56da604df 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97576,6 +97576,29 @@ creation of a LaTeX template if conditional paths for code execution are
 required.  All the commands work both in the preamble and in the document.")
     (license license:lppl1.3+)))
 
+(define-public texlive-termcal
+  (package
+    (name "texlive-termcal")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/termcal/" "source/latex/termcal/"
+                   "tex/latex/termcal/")
+             (base32
+              "0ikqi79g3vlcl7aqm4fdszz9172mgv8sd0b6gpx20pr74r6431p7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/termcal")
+    (synopsis "Print a class calendar")
+    (description
+     "This package is intended to print a term calendar for use in planning a class.
+It has a flexible mechanism for specifying which days of the week are to be
+included and for inserting text either regularly on the same day each week, or
+on selected days, or for a series of consecutive days.  It also has a flexible
+mechanism for specifing class and non-class days.  Text may be inserted into
+consecutive days so that it automatically flows around non-class days.")
+    (license license:lppl1.0+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar