summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 11:48:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-14 12:05:51 +0100
commit191e5674d9f1b2035f681a939c266efe2dd4a2dd (patch)
treebd23eb0d83c702c8f5458ec15d67621772b55d03 /gnu
parent1cfaa79e6d90eb3eaa476a15abc2c4ca8ee78e03 (diff)
downloadguix-191e5674d9f1b2035f681a939c266efe2dd4a2dd.tar.gz
gnu: go-github-com-golang-groupcache: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-golang-groupcache): Move
from here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: I3e5393d13630529a0cf309e08b9e7dc9d5cba18a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm31
-rw-r--r--gnu/packages/syncthing.scm28
2 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5c6d9126ef..9005a16ca7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,4 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2019, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
@@ -10,7 +11,6 @@
 ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
-;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -708,6 +708,35 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
      "Fast JSON encoder/decoder compatible with encoding/json for Go.")
     (license license:expat)))
 
+(define-public go-github-com-golang-groupcache
+  (let ((commit "869f871628b6baa9cfbc11732cdf6546b17c1298")
+        (revision "2"))
+    (package
+      (name "go-github-com-golang-groupcache")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/golang/groupcache")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0r4nk8129bvx50qb4xzjaay39b2h6k7cbdqqzdlanmc82ygczsbw"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "github.com/golang/groupcache"))
+      (propagated-inputs
+       (list go-github-com-golang-protobuf-proto))
+      (home-page "https://github.com/golang/groupcache")
+      (synopsis "Groupcache is a caching and cache-filling library")
+      (description
+       "Groupcache is a caching and cache-filling library, intended
+as a replacement for memcached in many cases.  It provides a data loading
+mechanism with caching and de-duplication that works across a set of peer
+processes.")
+      (license license:asl2.0))))
+
 (define-public go-github-com-google-go-github
   (package
     (name "go-github-com-google-go-github")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0914d618f5..366a5f0ebb 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -353,34 +353,6 @@ structs in the Go programming language.")
     (home-page "https://github.com/d4l3k/messagediff")
     (license expat)))
 
-(define-public go-github-com-golang-groupcache
-  (let ((commit "869f871628b6baa9cfbc11732cdf6546b17c1298")
-        (revision "2"))
-    (package
-      (name "go-github-com-golang-groupcache")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/golang/groupcache")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0r4nk8129bvx50qb4xzjaay39b2h6k7cbdqqzdlanmc82ygczsbw"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/golang/groupcache"))
-      (propagated-inputs
-       (list go-github-com-golang-protobuf-proto))
-      (synopsis "Groupcache is a caching and cache-filling library")
-      (description "Groupcache is a caching and cache-filling library, intended
-as a replacement for memcached in many cases.  It provides a data loading
-mechanism with caching and de-duplication that works across a set of peer
-processes.")
-      (home-page "https://github.com/golang/groupcache")
-      (license asl2.0))))
-
 (define-public go-github-com-jackpal-gateway
   (package
     (name "go-github-com-jackpal-gateway")