summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-05-06 22:26:56 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-13 16:27:40 +0200
commit1d9efb858fadb7668d3bea33288ce31d42806b6c (patch)
tree35bc76139f92e7bbd3bad6619803452c70aec914 /gnu
parented1e7920393c9ae5b2ae31fc46bae88136239b13 (diff)
downloadguix-1d9efb858fadb7668d3bea33288ce31d42806b6c.tar.gz
gnu: shepherd: Add 0.10.0.
* gnu/packages/admin.scm (shepherd-0.10): New variable.
(guile2.2-shepherd): Inherit from SHEPHERD-0.10.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 64d5182037..c0944685ea 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -367,11 +367,23 @@ interface and is based on GNU Guile.")
                          guile-fibers-1.1))       ;for cross-compilation
     (inputs (list guile-3.0-latest guile-fibers-1.1))))
 
+(define-public shepherd-0.10
+  (package
+    (inherit shepherd-0.9)
+    (version "0.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://alpha.gnu.org/gnu/shepherd/shepherd-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0dpbcq4jhqfv39jzc675ccidiyv8ziw5x9qv9kwxv132a5qf8phf"))))))
+
 (define-public shepherd shepherd-0.9)
 
 (define-public guile2.2-shepherd
   (package
-    (inherit shepherd-0.9)
+    (inherit shepherd-0.10)
     (name "guile2.2-shepherd")
     (native-inputs (list pkg-config guile-2.2))
     (inputs (list guile-2.2 guile2.2-fibers))))