summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-02-05 13:23:49 +0100
committerLeo Famulari <leo@famulari.name>2023-02-05 14:03:21 +0100
commit1ec22406b2f773e6c901b4afbc1a7723855a66f8 (patch)
treeee069b9dda6297da63e8ee5c7241f14c1bf5dbf5 /gnu
parent19e4bb8da2eab765da030107930b030540779585 (diff)
downloadguix-1ec22406b2f773e6c901b4afbc1a7723855a66f8.tar.gz
gnu: imv: Use new package style.
* gnu/packages/image-viewers.scm (imv)[arguments]: Use G-expressions.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-viewers.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0701f7bd4f..02e25aee5f 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -762,17 +762,15 @@ displayed in a terminal.")
               (file-name (git-file-name name version))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'record-absolute-file-names
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; 'imv' is a script that execs 'imv-x11' or 'imv-wayland'.
-             ;; Record their absolute file name.
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin")))
-               (substitute* (string-append bin "/imv")
-                 (("imv-")
-                  (string-append bin "/imv-")))))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'record-absolute-file-names
+                 (lambda _
+                   ;; 'imv' is a script that execs 'imv-x11' or 'imv-wayland'.
+                   ;; Record their absolute file name.
+                   (let ((bin (string-append #$output "/bin")))
+                     (substitute* (string-append bin "/imv")
+                       (("imv-") (string-append bin "/imv-")))))))))
     (native-inputs
      (list asciidoc
            pkg-config))