summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:44 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit2095fe7b9671b69b060dff8be2a4eea89cd61923 (patch)
tree2d2e75ace64fdb82e6181b3367378706b6ce2b88 /gnu
parente5b8a87b40710590421915bec0d0c161b684b9fc (diff)
downloadguix-2095fe7b9671b69b060dff8be2a4eea89cd61923.tar.gz
gnu: Add python-bayesicfitting.
* gnu/packages/astronomy.scm (python-bayesicfitting): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5c42512a0a..f2ef829ca9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1355,6 +1355,38 @@ be as fast as possible so some of the readability has been sacrificed,
 specifically in the C code.")
     (license license:bsd-3)))
 
+(define-public python-bayesicfitting
+  (package
+    (name "python-bayesicfitting")
+    (version "3.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dokester/BayesicFitting")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07y9dr9wxhxrvhk0jjakhbyrgal60i92m7z7q14fp12k8x0gl69l"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (invoke "python" "-m" "unittest" "discover"
+                                      "test")))))))
+    (propagated-inputs (list python-astropy python-future python-matplotlib
+                             python-numpy python-scipy))
+    (home-page "https://www.bayesicfitting.nl")
+    (synopsis "Python Toolbox for Astronimical Bayesian fitting")
+    (description
+     "The BayesicFitting package is a python version of the the fitter classes
+in @acronym{HCSS, Herschel Common Science System}.  HCSS was the all
+encompassing software system for the operations and analysis of the ESA satelite
+Herschel.")
+    (license license:gpl3+)))
+
 (define-public python-ccdproc
   (package
     (name "python-ccdproc")