summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:40:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:07 +0200
commit21b16bcdf99d92936a68fd649516583bf55a07d9 (patch)
treee7ba23abea81e4241a231e97039dc7911907180b /gnu
parent27c1972b61c3fe3e62e58532bb1a032f01d56a96 (diff)
downloadguix-21b16bcdf99d92936a68fd649516583bf55a07d9.tar.gz
gnu: Add texlive-spie.
* gnu/packages/tex.scm (texlive-spie): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a93384dba7..290aa7f5a0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27961,6 +27961,25 @@ However, modifying the class for conformation to a different guideline should
 not be difficult.")
     (license license:public-domain)))
 
+(define-public texlive-spie
+  (package
+    (name "texlive-spie")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bib/spie/" "bibtex/bst/spie/"
+                   "doc/latex/spie/" "tex/latex/spie/")
+             (base32
+              "1z4nbm2w96lvwfcj8ghnzarv5f5klriyr3b6jjnb34wd3kw52xg8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/spie")
+    (synopsis "Support for formatting SPIE Proceedings manuscripts")
+    (description
+     "This package provides support for formatting SPIE Proceedings
+manuscripts.  A class and a BibTeX style are provided.")
+    (license license:lppl)))
+
 (define-public texlive-splitbib
   (package
     (name "texlive-splitbib")