summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMattia Bunel <mattia.bunel@ign.fr>2024-01-05 14:50:53 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-07 19:25:46 +0100
commit224499f2d466b1a3f3a45e44a709a983185b69ca (patch)
treecff80db7a7ca03ccb9f41b14e61195c4630fb15f /gnu
parenta5d5c5b357515ec9365ee0b678fa29ac1f86288d (diff)
downloadguix-224499f2d466b1a3f3a45e44a709a983185b69ca.tar.gz
gnu: Add laszip.
* gnu/packages/geo.scm (laszip): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Change-Id: I8baf25f1d51c9ac90bcea4a1e9a564e21e0a9ee6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/geo.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 31abb2cc36..73b7aa3d11 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3228,3 +3228,31 @@ For maps, it can uses its own \"binfile\" map format, or Garmin map
 file format, and data from OpenStreetMap, Garmin maps, Marco Polo
 Grosser Reiseplaner, Routeplaner Europa 2007, Map + Route.")
     (license license:gpl2)))
+
+(define-public laszip
+  (package
+    (name "laszip")
+    (version "3.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/LASzip/LASzip")
+             (commit "3.4.3")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09lcsgxwv0jq50fhsgfhx0npbf1zcwn3hbnq6q78fshqksbxmz7m"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags #~(list "-DLASZIP_BUILD_STATIC=NO")
+      #:build-type "Release"
+      ;; No tests.
+      #:tests? #f))
+    (home-page "https://laszip.org/")
+    (synopsis "Compression library for LAS files")
+    (description
+     "LASzip is a library for compressing @code{LAS} files and uncompressing
+@code{LAZ} files.  The @code{LAS} format is a file format designed for the
+interchange and archiving of lidar point cloud data.")
+    (license license:asl2.0)))