summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-29 15:46:06 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-01 23:47:07 +0800
commit22e071e38ae6fb87a74df9c5ff645f0c5c551f32 (patch)
treeeae4b537138b8c5cc430cd03bae4df3779347e17 /gnu
parent882077fd30ac5bec90b074f4525a47a16a15f0a0 (diff)
downloadguix-22e071e38ae6fb87a74df9c5ff645f0c5c551f32.tar.gz
gnu: kvantum: Update to 1.1.2.
* gnu/packages/qt.scm (kvantum): Update to 1.1.2.
[source]: Switch to git-fetch.
[arguments]: Set #:qtbase to qtbase.
<#:phases>: Adjust patch-style-dir phase.
[inputs]: Remove libx11, libxext, qtbase-5, qtsvg-5, and qtx11extras; add qtsvg.
[native-inputs]: Remove qttools-5; add qttools.

Change-Id: I1dbfe5587467df747f91eccbc2b3ce3f3ed21e31
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c150dca78b..a91bebf358 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -313,19 +313,21 @@ Qt.  Some of its features include:
 (define-public kvantum
   (package
     (name "kvantum")
-    (version "1.0.7")
+    (version "1.1.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/tsujan/Kvantum/releases/download/V"
-                    version "/Kvantum-" version ".tar.xz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tsujan/Kvantum")
+                    (commit (string-append "V" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0zwxswbgd3wc7al3fhrl5qc0fmmb6mkygywjh1spbqpl7s8jw5s3"))))
+                "1prlv2fqwbxj9fqs4xf925qh9m9ginh0mcc618yg3h23vxq9g9ym"))))
     (build-system qt-build-system)
     (arguments
      (list
       #:tests? #f                       ;no tests
+      #:qtbase qtbase
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'chdir
@@ -336,15 +338,11 @@ Qt.  Some of its features include:
               (substitute* "style/CMakeLists.txt"
                 (("\\$\\{KVANTUM_STYLE_DIR\\}")
                  (string-append #$output
-                                "/lib/qt5/plugins/styles"))))))))
-    (native-inputs (list qttools-5))
+                                "/lib/qt6/plugins/styles"))))))))
+    (native-inputs (list qttools))
     (inputs (list
              kwindowsystem
-             libx11
-             libxext
-             qtbase-5
-             qtsvg-5
-             qtx11extras))
+             qtsvg))
     (synopsis "SVG-based theme engine for Qt")
     (description
      "Kvantum is an SVG-based theme engine for Qt,