summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:01:07 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:26 +0100
commit2494d95ededf2ab41a2c3e53ab5c0500a834f3b7 (patch)
tree97d0e1d478ff9d989341d692247d78254d2678da /gnu
parent5cc35758e50da0b92fedc0f4460874cef3fd51a8 (diff)
downloadguix-2494d95ededf2ab41a2c3e53ab5c0500a834f3b7.tar.gz
gnu: Add go-github-com-thejerf-suture-v4.
* gnu/packages/golang-xyz.scm (go-github-com-thejerf-suture-v4): New variable.

Change-Id: If54702c8b0a9eec19af72dc513a8d6551966fc2d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 267b5a3f6b..0f12b58487 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3555,6 +3555,21 @@ code, and providing hooks to perform adequate logging with in a production
 environment")
     (license license:expat)))
 
+(define-public go-github-com-thejerf-suture-v4
+  (package
+    (inherit go-github-com-thejerf-suture)
+    (name "go-github-com-thejerf-suture-v4")
+    (version "4.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/thejerf/suture")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15qi7v2a1kbf70yi3w6y26wbwj0sm8hv9f6xjrb4rl6nv9l8j88c"))))))
+
 (define-public go-github-com-tidwall-gjson
   (package
     (name "go-github-com-tidwall-gjson")