summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:31:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:00 +0200
commit24f45cec44cd24887a1def948b12937a04867e8e (patch)
tree812c3ea4f10d28da079e9eb4cb8ca9788764bbe8 /gnu
parent0664f43a65fd6bb45173c7c85840731dfe470ac0 (diff)
downloadguix-24f45cec44cd24887a1def948b12937a04867e8e.tar.gz
gnu: Add texlive-revtex4.
* gnu/packages/tex.scm (texlive-revtex4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ea8f43a37e..8eadc73631 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -26241,6 +26241,25 @@ provides fallbacks.  It also warns when users try to load packages which are
 known to be incompatible with @code{revtex4-1}.")
     (license license:lppl1.3+)))
 
+(define-public texlive-revtex4
+  (package
+    (name "texlive-revtex4")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/revtex4/" "doc/latex/revtex4/"
+                   "source/latex/revtex4/" "tex/latex/revtex4/")
+             (base32
+              "0mfjp8ycsvq63vk5348r7yfcskldx6ipcwflxz7pnf60xfla5646")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/revtex4-0")
+    (synopsis "Styles for various physics journals (old version)")
+    (description
+     "This is an old version of @code{revtex}, and is kept as a courtesy to
+users having difficulty with the incompatibility of that latest version.")
+    (license license:lppl)))
+
 (define-public texlive-ribbonproofs
   (package
     (name "texlive-ribbonproofs")