summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:40:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:07 +0200
commit27c1972b61c3fe3e62e58532bb1a032f01d56a96 (patch)
tree6b43ab1d2e1fec18f1ea30818c614a9bf4148592 /gnu
parent29f1118b9650e64aa9395a62784823798d9a74d2 (diff)
downloadguix-27c1972b61c3fe3e62e58532bb1a032f01d56a96.tar.gz
gnu: Add texlive-sphdthesis.
* gnu/packages/tex.scm (texlive-sphdthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0137c811cf..a93384dba7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27939,6 +27939,28 @@ a new and versatile serif face available in seven weights of roman and italic,
 with small caps.")
     (license (list license:silofl1.1 license:lppl))))
 
+(define-public texlive-sphdthesis
+  (package
+    (name "texlive-sphdthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sphdthesis/"
+                   "tex/latex/sphdthesis/")
+             (base32
+              "05ncll9vd2yh15vp6gqzidrp011d1i2hsmlzfrfz954f9449ydx4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sphdthesis")
+    (synopsis "LaTeX template for writing PhD thesis")
+    (description
+     "The package provides a LaTeX document class for writing a PhD thesis.
+By default, the class adheres to the @acronym{NUS, National University of
+Singapore} Guidelines on Format of Research Thesis Submitted For Examination.
+However, modifying the class for conformation to a different guideline should
+not be difficult.")
+    (license license:public-domain)))
+
 (define-public texlive-splitbib
   (package
     (name "texlive-splitbib")