summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:00:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:14 +0200
commit297e8f0319a2fc3c872fb79633ed21b04424a2ca (patch)
treeca8f10af9e0212181c4127f715a3783658b26f2e /gnu
parentb9c410c089b535f283617f81bc193d8b4934bbc8 (diff)
downloadguix-297e8f0319a2fc3c872fb79633ed21b04424a2ca.tar.gz
gnu: Add texlive-tugboat.
* gnu/packages/tex.scm (texlive-tugboat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eb73775e08..98a76acc6e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -30217,6 +30217,26 @@ headings in @code{twocolumn} layout.
 @end itemize")
     (license license:lppl1.3c)))
 
+(define-public texlive-tugboat
+  (package
+    (name "texlive-tugboat")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/tugboat/" "doc/latex/tugboat/"
+                   "source/latex/tugboat/" "tex/latex/tugboat/")
+             (base32
+              "1yf9g7bszxdkzb4calsd03kwnjs4i0y7vh0d7z4fwiv49qrbkzks")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tugboat")
+    (synopsis "LaTeX macros for @emph{TUGboat} articles")
+    (description
+     "This package provides @file{ltugboat.cls} for both regular and
+proceedings issues of the @emph{TUGboat} journal.  It also provides a BibTeX
+style, @file{tugboat.bst}.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-turabian-formatting
   (package
     (name "texlive-turabian-formatting")