summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-02 19:31:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-03 11:16:13 -0400
commit2b08945cbb0b9557a798af4be6438e1e97444a0e (patch)
treeef413c933cf2212507185a7389eeacbf58681400 /gnu
parent9945f9419df0f3b38f839cf40baa2732c5de8550 (diff)
downloadguix-2b08945cbb0b9557a798af4be6438e1e97444a0e.tar.gz
gnu: gf2x: Migrate from gforge.inria.fr to gitlab.inria.fr.
* gnu/packages/algebra.scm (gf2x) [source]: Fetch from git, adjust URL.
[native-inputs]: Add autoconf, automake and libtool.
[home-site]: Update URL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 183d84c549..4d49e07cc5 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -106,24 +106,26 @@ multiplication routines such as Toom–Cook and the FFT.")
 
 (define-public gf2x
   (package
-   (name "gf2x")
-   (version "1.2")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append
-                  "https://gforge.inria.fr/frs/download.php/file/36934/gf2x-"
-                  version ".tar.gz"))
-            (sha256
-             (base32
-              "0d6vh1mxskvv3bxl6byp7gxxw3zzpkldrxnyajhnl05m0gx7yhk1"))))
-   (build-system gnu-build-system)
-   (synopsis "Arithmetic of polynomials over binary finite fields")
-   (description
-    "The gf2x library provides arithmetic of polynomials over finite fields
+    (name "gf2x")
+    (version "1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.inria.fr/gf2x/gf2x")
+                    (commit (string-append name "-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0521pkhwj7x6www4phraqzm9f7rdpi37vvmd33badkba17cdb40d"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
+    (synopsis "Arithmetic of polynomials over binary finite fields")
+    (description
+     "The gf2x library provides arithmetic of polynomials over finite fields
 of characteristic 2.  It implements the multiplication, squaring and
 greatest common divisor operations.")
-   (license license:gpl3+)
-   (home-page "https://gforge.inria.fr/projects/gf2x/")))
+    (home-page "https://gitlab.inria.fr/gf2x/gf2x")
+    (license license:gpl3+)))
 
 (define-public cm
   (package