summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-06 14:16:29 -0300
committerVinicius Monego <monego@posteo.net>2024-07-06 23:05:52 -0300
commit2b276ae80feadda01d58eb13bb72b96cd0d9c998 (patch)
tree57d05adf6e19d1345252aceb13a55c8d00b84b93 /gnu
parent5dad9f67018ab0e7c03d490270e04adc27b554a5 (diff)
downloadguix-2b276ae80feadda01d58eb13bb72b96cd0d9c998.tar.gz
gnu: xonsh: Improve package style.
* gnu/packages/shells.scm (xonsh)[source](snippet): Remove trailing #t.
[arguments]<#:phases>: Use #$output rather than the outputs alist.

Change-Id: I30c1b1d8e64ba6bbce61e47cbfec91de3d3df7ae
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 6e2cca4bdb..28d5670a1d 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -576,8 +576,7 @@ ksh, and tcsh.")
                                 "xonsh/xonfig.py")
                (("from xonsh\\.ply\\.(.*) import" _ module)
                 (format #f "from ~a import" module))
-               (("from xonsh\\.ply import") "import"))
-             #t))))
+               (("from xonsh\\.ply import") "import"))))))
     (build-system pyproject-build-system)
     (arguments
      ;; Some tests are failing for reasons like not accessing parent directory
@@ -613,12 +612,11 @@ ksh, and tcsh.")
            #:phases
            #~(modify-phases %standard-phases
                (replace 'install
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (let* ((out (assoc-ref outputs "out")))
-                     (invoke "python" "-m" "compileall"
-                             "--invalidation-mode=unchecked-hash" out)
-                     (invoke "python" "setup.py" "install" "--root=/"
-                             (string-append "--prefix=" out)))))
+                 (lambda _
+                   (invoke "python" "-m" "compileall"
+                           "--invalidation-mode=unchecked-hash" #$output)
+                   (invoke "python" "setup.py" "install" "--root=/"
+                           (string-append "--prefix=" #$output))))
                ;; Some tests run os.mkdir().
                (add-before 'check 'writable-home
                  (lambda _