summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2024-03-26 17:01:04 -0300
committerChristopher Baines <mail@cbaines.net>2024-03-27 12:30:55 +0000
commit2ba3bd786e37115facd6e59357dc2123df973fa8 (patch)
tree6419ee4fc74be8a8a2e5d2f5e5ce3f04c9b62b6a /gnu
parent62314e54d141ff0d835e8f19df71628da8c402f3 (diff)
downloadguix-2ba3bd786e37115facd6e59357dc2123df973fa8.tar.gz
gnu: moonfish: Update to 0-2.fb2cb4f.
* gnu/packages/games.scm (moonfish): Update to 0-2.fb2cb4f.
[arguments]: Use upstream's makefile for building and installing.
Install tools into the "out" output instead of the "tools" output.
[outputs]: Remove "tools".

Change-Id: I0f098b02633d397fe1fef67863c3cd5b1db19214
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm33
1 files changed, 8 insertions, 25 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f150c33e83..13976666e6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10618,8 +10618,8 @@ ChessX.")
       (license license:gpl3+))))
 
 (define-public moonfish
-  (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
-        (revision "1"))
+  (let ((commit "fb2cb4f53876b1b0c6060464e0dd5a05ab00e502")
+        (revision "2"))
     (package
       (name "moonfish")
       (version (git-version "0" revision commit))
@@ -10630,34 +10630,17 @@ ChessX.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
+                  "1rbhdahp0s2qm1zi7lpr0bb6zq02y76fc9d9nc2k5n03zh2as97i"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
        (list
-        #:make-flags
-        #~(list (string-append "CC=" #$(cc-for-target)))
-        #:tests? #f                     ;no check target
-        #:phases
-        #~(modify-phases %standard-phases
-            (delete 'configure)         ;no configure script
-            (replace 'install           ;no 'install' target
-              (lambda _
-                (let* ((out-bin (string-append #$output "/bin"))
-                       (tools-bin (string-append #$output:tools "/bin"))
-                       (tool (string-append tools-bin "/moonfish-")))
-                  (mkdir-p out-bin)
-                  (mkdir-p tools-bin)
-                  (copy-file "moonfish"
-                             (string-append out-bin "/moonfish"))
-                  (copy-file "play"
-                             (string-append tool "play"))
-                  (copy-file "lichess"
-                             (string-append tool "lichess"))
-                  (copy-file "analyse"
-                             (string-append tool "analyse"))))))))
+        #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                             (string-append "PREFIX=" %output))
+        #:tests? #f ;no check target
+        #:phases #~(modify-phases %standard-phases
+                     (delete 'configure)))) ;no configure script
       (inputs (list bearssl cjson))
-      (outputs '("out" "tools"))
       (home-page "https://git.sr.ht/~zamfofex/moonfish")
       (synopsis "Simple chess engine written in C")
       (description