summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-12 14:03:19 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-12 17:41:38 +0900
commit2bad254d032fca2843ffdaff401619c7cecc7c5a (patch)
tree6a276708cb2af4590769770b19233ecb7cf80909 /gnu
parent4bfe5fc5846fadf505e08b1df4f5d27f63ce08c9 (diff)
downloadguix-2bad254d032fca2843ffdaff401619c7cecc7c5a.tar.gz
gnu: yosys: Update to 0.47.
* gnu/packages/fpga.scm (yosys): Update to 0.47.
[arguments]: Extend fix-paths phase.
[native-inputs]: Add cxxopts.

Change-Id: I14afed45261e7c4830fe91fe2ced8762eed54810
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fpga.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 6064b2019b..ae326b1138 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -45,6 +45,7 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gawk)
@@ -149,7 +150,7 @@ For synthesis, the compiler generates netlists in the desired format.")
 (define-public yosys
   (package
     (name "yosys")
-    (version "0.46")
+    (version "0.47")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -157,7 +158,7 @@ For synthesis, the compiler generates netlists in the desired format.")
                     (commit version)))
               (sha256
                (base32
-                "1zj7vbpy6v1wn4p5cjs4hdjd467a1j1aj2qhs148bl2s6mzq3p86"))
+                "061sqb59vl61rshlwgv3n51x0fxd9x3lb6gfbdl7nzia8im7x0qm"))
               (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
@@ -178,6 +179,9 @@ For synthesis, the compiler generates netlists in the desired format.")
                  (search-input-file inputs "/bin/vcd2fst")))
               (substitute* '("./passes/cmds/show.cc"
                              "./passes/cmds/viz.cc")
+              (substitute* "kernel/driver.cc"
+                (("^#include \"libs/cxxopts/include/cxxopts.hpp\"")
+                 "#include <cxxopts.hpp>"))
                 (("exec xdot")
                  (string-append "exec " (search-input-file inputs
                                                            "/bin/xdot")))
@@ -208,6 +212,7 @@ For synthesis, the compiler generates netlists in the desired format.")
                 `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))))))))
     (native-inputs
      (list bison
+           cxxopts                      ;header-only library
            flex
            gawk ; for the tests and "make" progress pretty-printing
            iverilog ; for the tests