summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-21 12:06:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-21 16:39:26 +0300
commit2c17bd7b2955beef4130d11b33e07e4fb3b234dc (patch)
tree47bd39ae34b1f7925ee37b93b26dacfeca99e7e1 /gnu
parent617c478506888daea35dceeda3679196eb8a5177 (diff)
downloadguix-2c17bd7b2955beef4130d11b33e07e4fb3b234dc.tar.gz
gnu: kodi: Disable version checker.
Fixes bug#32997.

* gnu/packages/kodi.scm (kodi)[arguments]: Add substitution to remove
the version checking configuration option.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kodi.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 86ce914d53..21e7b12d3e 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -317,6 +317,11 @@ generator library for C++.")
                 (string-append (assoc-ref inputs "tzdata")
                                "/share/zoneinfo")))
 
+             ;; Don't phone home to check for updates.¬
+             (substitute* "system/addon-manifest.xml"¬
+               (("<addon optional=\\\"true\\\">service.xbmc.versioncheck</addon>")
+                ""))
+
              ;; Let's disable some tests that are known not to work here.
              ;; Doing this later while in the cmake "../build" directory
              ;; is trickier.