summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-01 23:07:30 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-17 00:19:32 +0100
commit2d4589ffb9be291cd9e76476d9385013fefb3600 (patch)
tree46a53a32c79d5858ceb3403eebbd6877682683c3 /gnu
parent22fe9110612401e879764564ca2078dce0836fff (diff)
downloadguix-2d4589ffb9be291cd9e76476d9385013fefb3600.tar.gz
gnu: kcoreaddons: Enable test-suite.
Enable running the tests and blacklist the one failing test.

* gnu/package/kde-frameworks.scm(kcoreaddons)[arguments]
  <#:tests?>: Remove. <#:phases>: Add phase 'blacklist-failing-test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 42b9f0f6bf..3a6c9f6b14 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -567,9 +567,16 @@ propagate their changes to their respective configuration files.")
     (inputs
      `(("qtbase" ,qtbase)))
     (arguments
-     `(#:tests? #f ; FIXME: Test failure caused by stout/stderr being interleaved.
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
+         (add-before 'check 'blacklist-failing-test
+           (lambda _
+             ;; Blacklist a failing test-function. FIXME: Make it pass.
+             ;; Test failure caused by stout/stderr being interleaved.
+             (with-output-to-file "autotests/BLACKLIST"
+               (lambda _
+                 (display "[test_channels]\n*\n")))
+             #t))
          (add-before 'check 'check-setup
            (lambda _
              (setenv "HOME" (getcwd))