summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-19 10:45:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-19 11:07:55 +0100
commit32b7ccf9b4c490613395d5f8ad06334c797e47e0 (patch)
tree00bb2675e9a952a5c19b6c739586954dcf07ba0a /gnu
parent2915221bcba0ee152b9d1910ec2462f2d5ebf8e7 (diff)
downloadguix-32b7ccf9b4c490613395d5f8ad06334c797e47e0.tar.gz
gnu: pigx-chipseq: Update to 0.0.8.
* gnu/packages/bioinformatics.scm (pigx-chipseq): Update to 0.0.8.
[inputs]: Add python-magic, python-xlrd, and trim-galore.
[arguments]: Disable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 91f5d617eb..80f1437f22 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12737,7 +12737,7 @@ expression report comparing samples in an easily configurable manner.")
 (define-public pigx-chipseq
   (package
     (name "pigx-chipseq")
-    (version "0.0.2")
+    (version "0.0.8")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/BIMSBbioinfo/pigx_chipseq/"
@@ -12745,10 +12745,11 @@ expression report comparing samples in an easily configurable manner.")
                                   "/pigx_chipseq-" version ".tar.gz"))
               (sha256
                (base32
-                "1jliwhifnjgl9x0z730bzpxswi2s84fyg5y8cagbyzpw509452f5"))))
+                "1plw0bz0b7flj0g9irbn8n520005lmajkiq5flpizzapsl0a0r9g"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:tests? #f ; parts of the tests rely on access to the network
+       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap-executable
            ;; Make sure the executable finds all R modules.
@@ -12773,8 +12774,11 @@ expression report comparing samples in an easily configurable manner.")
        ("r-ggplot2" ,r-ggplot2)
        ("r-plotly" ,r-plotly)
        ("python-wrapper" ,python-wrapper)
+       ("python-magic" ,python-magic)
        ("python-pyyaml" ,python-pyyaml)
+       ("python-xlrd" ,python-xlrd)
        ("snakemake" ,snakemake)
+       ("trim-galore" ,trim-galore)
        ("macs" ,macs)
        ("multiqc" ,multiqc)
        ("perl" ,perl)