summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:51:48 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 17:04:23 +0200
commit3540c6eb2b51f98f0243170ce55b4ec3eede0983 (patch)
treefbe3ffb24c6ef4c8ffc2a05aa52de6395f83b8d0 /gnu
parent2dcea9b446dec427ad3d6d0e23af647d0bb34649 (diff)
downloadguix-3540c6eb2b51f98f0243170ce55b4ec3eede0983.tar.gz
gnu: Add emacs-helm-company.
* gnu/packages/emacs.scm (emacs-helm-company): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8c99232c8e..96bb8cbc9d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10886,3 +10886,29 @@ the GIF result.")
        "This packages provides an Emacs interface to the Google Translate
 on-line service.")
       (license license:gpl3+))))
+
+(define-public emacs-helm-company
+  (let ((commit "acc9c7901e094c1591327a0db1ec7a439f67a84d"))
+    (package
+      (name "emacs-helm-company")
+      (version (git-version "0.2.2" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Sodel-the-Vociferous/helm-company")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "1d4q9clp0q56br80c21a4wz1gc4jw3mdy97z9mq07x9i8rhlppzs"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-helm" ,emacs-helm)
+         ("emacs-company" ,emacs-company)))
+      (home-page "https://github.com/Sodel-the-Vociferous/helm-company")
+      (synopsis "Helm interface for company-mode")
+      (description
+       "This is a Helm interface to company-mode, a text completion
+framework.")
+      (license license:gpl3+))))