summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-04-09 12:22:37 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-15 10:14:06 +0100
commit39689ffd30f566cdc91704825389e1897e002e20 (patch)
tree155d48ec22ec7ab3874206c61ed6943165fca23f /gnu
parent949c3682b7e4ba29c47c1fd92aecbca815b19d68 (diff)
downloadguix-39689ffd30f566cdc91704825389e1897e002e20.tar.gz
gnu: coin3d: Avoid use of dlopen.
* gnu/packages/graphics.scm (coin3d): Avoid use of dlopen and add
missing inputs.

Change-Id: I48d93218bd93f6ef4f10fb1c4f1cc22396040d7d
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7f704c3e58..5d7c95a2a9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -81,6 +81,7 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnunet)
+  #:use-module (gnu packages gnuzilla)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
@@ -1986,12 +1987,31 @@ or by subtracting one shape from the other.")
      (list #:configure-flags
            #~(list "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
                    "-DUSE_EXTERNAL_EXPAT=ON"
+                   ;; Disable "runtime linking" of libraries, i.e. `dlopen`,
+                   ;; force to use libraries at build time.
+                   "-DFONTCONFIG_RUNTIME_LINKING=OFF"
+                   "-DFREETYPE_RUNTIME_LINKING=OFF"
+                   "-DLIBBZIP2_RUNTIME_LINKING=OFF"
+                   "-DOPENAL_RUNTIME_LINKING=OFF"
+                   ;"-DSIMAGE_RUNTIME_LINKING=OFF" -- Not packaged yet.
+                   "-DZLIB_RUNTIME_LINKING=OFF"
+                   "-DGLU_RUNTIME_LINKING=OFF"
+                   ;"-DSPIDERMONKEY_RUNTIME_LINKING=OFF" -- Can't find mozjs.
                    (string-append "-DBOOST_ROOT="
                                   #$(this-package-input "boost")))))
     (native-inputs
      (list doxygen graphviz))
     (inputs
-     (list boost expat freeglut glew))
+     (list boost
+           bzip2
+           expat
+           fontconfig
+           freeglut
+           freetype
+           glew
+           libx11
+           openal
+           zlib))
     (home-page "https://github.com/coin3d/coin")
     (synopsis
      "High-level 3D visualization library with Open Inventor 2.1 API")