summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:07:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:20 +0200
commit39a3923eecf04ca133e1f26d364d699860e986b4 (patch)
treee8e0c654e54393e7c2f2771e20b571e9a1c2ed66 /gnu
parent1c72df969252c9e644fd0392dd4f49de315e6525 (diff)
downloadguix-39a3923eecf04ca133e1f26d364d699860e986b4.tar.gz
gnu: Add texlive-umich-thesis.
* gnu/packages/tex.scm (texlive-umich-thesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b712acbb2b..89953d70d6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -30825,6 +30825,25 @@ Association Bills")
 Government Association Bills.")
     (license license:gpl3)))
 
+(define-public texlive-umich-thesis
+  (package
+    (name "texlive-umich-thesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/umich-thesis/"
+                   "tex/latex/umich-thesis/")
+             (base32
+              "15y25n9j2zh7hmgpq9fir6y0ydjwqhvyy6cx59jm8i0swkgw33vz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/umich-thesis")
+    (synopsis "University of Michigan thesis LaTeX class")
+    (description
+     "This package provides a LaTeX2e class to create a University of
+Michigan dissertation according to the Rackham dissertation handbook.")
+    (license license:lppl)))
+
 (define-public texlive-umtypewriter
   (package
     (name "texlive-umtypewriter")