summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 17:03:27 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commit39bbf6131c4a3fea15a279d9a69ed8ad0e308e75 (patch)
tree6d84858e5c601bcb5b7cd3e1147f763f4472801f /gnu
parent7bda142b559ec8a276b5b7124011bff09a5c3c6c (diff)
downloadguix-39bbf6131c4a3fea15a279d9a69ed8ad0e308e75.tar.gz
gnu: Add Sub-Name.
* gnu/packages/perl.scm (perl-sub-name): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a4aa11c0d4..fb5c90ea3f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1468,6 +1468,28 @@ the unsightly mess of C<no strict> or typeglobs lying about where just anyone
 can see them.")
     (license (package-license perl))))
 
+(define-public perl-sub-name
+  (package
+    (name "perl-sub-name")
+    (version "0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "Sub-Name-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1sdlc8pv7vyyc48gzh70hbwzn0hzwl3zbcy2dkmfw8vjzgya5i06"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-devel-checkbin" ,perl-devel-checkbin)))
+    (home-page "http://search.cpan.org/dist/Sub-Name")
+    (synopsis "(Re)name a sub")
+    (description "Assigns a new name to referenced sub.  If package
+specification is omitted in the name, then the current package is used.  The
+return value is the sub.")
+    (license (package-license perl))))
+
 (define-public perl-sub-uplevel
   (package
     (name "perl-sub-uplevel")