summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 14:42:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:26 +0100
commit3a94f439b39f3f4e11dd8feeb77bfc4e35d4735d (patch)
tree0eca1597ab1660ac7e3579a8b467405f9e30f29d /gnu
parent9bcb67166f7bb5ad2a3e62a90bfca076bb9fbded (diff)
downloadguix-3a94f439b39f3f4e11dd8feeb77bfc4e35d4735d.tar.gz
gnu: go-github-com-oschwald-maxminddb-golang: Enable tests.
* gnu/packages/golang-web.scm (go-github-com-oschwald-maxminddb-golang):
Enable tests.
[native-inputs]: Add go-github-com-stretchr-testify.

Change-Id: Idf3c98bdf832422779b045adb348dfaea6f8d3e2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b727a0165a..0b4970f5d5 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1846,8 +1846,25 @@ which produce colorized output using github.com/fatih/color.")
     (arguments
      (list
       #:go go-1.21
-      #:tests? #f ; Requires some unpackaged software and test data
-      #:import-path "github.com/oschwald/maxminddb-golang"))
+      #:import-path "github.com/oschwald/maxminddb-golang"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Remove most of the tests requiring test-data from submodule
+          ;; <https://github.com/maxmind/MaxMind-DB>, there is a documented
+          ;; process on how to generate it, consider to pack and activate
+          ;; tests in the next update cycle.
+          (add-after 'unpack 'remove-failing-tests
+            (lambda* (#:key import-path #:allow-other-keys)
+              (with-directory-excursion (string-append "src/" import-path)
+                (for-each delete-file
+                          (list "decoder_test.go"
+                                "deserializer_test.go"
+                                "example_test.go"
+                                "reader_test.go"
+                                "traverse_test.go"
+                                "verifier_test.go"))))))))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
     (propagated-inputs
      (list go-golang-org-x-sys))
     (home-page "https://github.com/oschwald/maxminddb-golang")