summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:06:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:41 +0200
commit3de2c32e34a3acbe65860d703d0dac2670a97619 (patch)
treebb7439e1fcaaa7ab7a6f1550ca128203b65b9b38 /gnu
parentcc4f1a381dce5618ff9058d9913fdd3bd9dd903a (diff)
downloadguix-3de2c32e34a3acbe65860d703d0dac2670a97619.tar.gz
gnu: Add texlive-minimalist.
* gnu/packages/tex.scm (texlive-minimalist): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8a68ff27f5..6086bc073c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21114,6 +21114,30 @@ with an easy syntax.  Minus signs are printed as bar above the corresponding
 number.")
     (license license:lppl)))
 
+(define-public texlive-minimalist
+  (package
+    (name "texlive-minimalist")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/minimalist/"
+                   "tex/latex/minimalist/")
+             (base32
+              "01j72iqf15jx3larxkmcvsviw1z9wba9vl5g0x6d1ch3jpg32xpg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-projlib))
+    (home-page "https://ctan.org/pkg/minimalist")
+    (synopsis "Write your articles or books in a simple and clear way")
+    (description
+     "This package offers you a LaTeX style file and two classes to typeset
+articles or books in a simple and clear way.  These classes currently have
+native support for English, French, German, Italian, Portuguese (European and
+Brazilian), and Spanish typesetting.  They compile with any major TeX engine.
+You may also wish to consider the packages @code{einfart} and
+@code{simplivre}, which are enhanced versions of the classes provided here.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-mintspirit
   (package
     (name "texlive-mintspirit")