summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-01-17 12:18:39 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-01-17 12:20:54 +0100
commit3e1fcc5ef41df4fa34e4bc9252c0a8582a77ad79 (patch)
treefdf74a9b9cca42001739b572f5374003a3cd6166 /gnu
parent5544a07fb52e0e92b5d0616ff1953d522dad1f0a (diff)
downloadguix-3e1fcc5ef41df4fa34e4bc9252c0a8582a77ad79.tar.gz
gnu: Add emacs-ctable.
* gnu/packages/emacs-xyz.scm (emacs-ctable): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad64f2a0b6..75f705a1ec 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12722,3 +12722,24 @@ customize the place of pop-up window, how the windows are split, how the
 buffers are located in the windows, keybinds to manipulate windows and
 buffers, etc.  It also has plug-ins to help your Emacs life.")
       (license license:gpl3+)))
+
+(define-public emacs-ctable
+  (let ((commit "b8830d1ca95abb100a81bc32011bd17d5ecba000"))
+    (package
+      (name "emacs-ctable")
+      (version (git-version "0.1.2" "1" commit))
+      (home-page "https://github.com/kiwanami/emacs-ctable")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0pg303pnqscrsbx9579hc815angszsgf9vpd2z2f8p4f4ka6a00h"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (synopsis "Table component for Emacs Lisp")
+      (description "This program is a table component for Emacs Lisp.  Other
+programs can use this table component for the application UI.")
+      (license license:gpl3+))))