summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:54 +0200
commit3fdffbeb64d9bf636a3b7b6cc6fa1d5ae4001727 (patch)
tree6506010c9b7a33cf5347813d1721321c5c6de058 /gnu
parent3ab796456e2d57534d53a167cf5f6601e5614c8f (diff)
downloadguix-3fdffbeb64d9bf636a3b7b6cc6fa1d5ae4001727.tar.gz
gnu: Add texlive-theoremref.
* gnu/packages/tex.scm (texlive-theoremref): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 04c338b601..77197d7a5b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98005,6 +98005,28 @@ compilation process.")
 MediaWiki to LaTeX documents.")
     (license license:lppl1.3+)))
 
+(define-public texlive-theoremref
+  (package
+    (name "texlive-theoremref")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/theoremref/"
+                   "tex/latex/theoremref/")
+             (base32
+              "1f2897nw1qsfp3lydx1v0ph9vyvwc0ms2azln69wr8ijh3lgyack")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/theoremref")
+    (synopsis "References with automatic theorem names")
+    (description
+     "The @code{theoremref} package provides variants of the @code{\\label} and
+@code{\\ref} commands for @code{theorem}-like environments, capable of
+automatically typesetting references including the theorem name (apart from
+the theorem number).  The scheme is particularly valuable if the author
+decides to change a lemma to a proposition or a theorem (or whatever).")
+    (license (list license:lppl license:gpl2))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar